dev-python/virtualenv: arm64 keyworded (bug #700918)
[gentoo.git] / dev-python / ansi2html / ansi2html-1.5.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Convert text with ANSI color codes to HTML"
11 HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-3+"
15 SLOT="0"
16 KEYWORDS="amd64 arm x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
23 DEPEND="
24         test? (
25                 ${RDEPEND}
26                 dev-python/nose[${PYTHON_USEDEP}]
27         )
28         dev-python/setuptools[${PYTHON_USEDEP}]
29         "
30
31 src_compile() {
32         distutils-r1_src_compile
33 }
34
35 python_test() {
36         chmod -x "${S}"/tests/* || die
37         esetup.py check
38         esetup.py test
39 }
40
41 python_install_all() {
42         doman man/${PN}.1
43         DOCS=( README.rst man/${PN}.1.txt )
44         distutils-r1_python_install_all
45 }