net-im/ktp-text-ui: EAPI 6, pin slots
[gentoo.git] / dev-python / amqplib / amqplib-0.6.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1 eutils
9
10 DESCRIPTION="Python client for the Advanced Message Queuing Procotol (AMQP)"
11 HOMEPAGE="https://code.google.com/p/py-amqplib/"
12 SRC_URI="https://py-amqplib.googlecode.com/files/${P}.tgz"
13
14 LICENSE="LGPL-3"
15 SLOT="0"
16 KEYWORDS="~x86 ~amd64"
17 IUSE="examples extras test"
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 RDEPEND=""
21
22 PATCHES=(
23         "${FILESDIR}/${P}_disable_socket_tests.patch"
24 )
25
26 python_test() {
27         "${PYTHON}" tests/client_0_8/run_all.py \
28                 || die "Tests fail with ${EPYTHON}"
29 }
30
31 python_install_all() {
32         distutils-r1_python_install_all
33
34         dodoc -r docs/.
35         if use examples; then
36                 docinto examples
37                 dodoc -r demo/.
38         fi
39         if use extras; then
40                 insinto /usr/share/${PF}
41                 doins -r extras
42         fi
43 }