dev-python/cython: Drop some intermediate Versions, which seem to cause problems
[gentoo.git] / dev-python / algopy / algopy-0.5.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 python3_{3,4} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Taylor Arithmetic Computation and Algorithmic Differentiation"
12 HOMEPAGE="https://pypi.python.org/pypi/algopy http://packages.python.org/algopy"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 SLOT="0"
16 LICENSE="BSD"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19
20 RDEPEND="
21         dev-python/numpy[${PYTHON_USEDEP}]
22         sci-libs/scipy[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         test? ( dev-python/nose[${PYTHON_USEDEP}] )
26 "
27
28 python_test() {
29         ${EPYTHON} run_tests.py || die
30 }