dev-python/sunpy: use HTTPS
[gentoo.git] / dev-python / alembic / alembic-0.9.5.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
10 HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm64 ~x86"
16 IUSE="test doc"
17
18 # requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
19 # because it shatters the testsuite.  If 'someone' cares to adhere to correct form
20 # and edit to -0.7.3, feel free, and then pick up the pieces.
21 RDEPEND=">=dev-python/sqlalchemy-0.8.4[${PYTHON_USEDEP}]
22         dev-python/mako[${PYTHON_USEDEP}]
23         >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
24         dev-python/python-dateutil[${PYTHON_USEDEP}]"
25 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
26         test? ( ${RDEPEND}
27                 dev-python/nose[${PYTHON_USEDEP}]
28                 dev-python/mock[${PYTHON_USEDEP}] )"
29 # For test phase
30 DISTUTILS_IN_SOURCE_BUILD=1
31
32 python_prepare_all() {
33         # suite passes all if run from source. The residual fail & error are quite erroneous
34         rm tests/test_script_consumption.py || die
35
36         distutils-r1_python_prepare_all
37 }
38
39 python_test() {
40         ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
41 }
42
43 python_install_all() {
44         use doc && local HTML_DOCS=( docs/. )
45
46         distutils-r1_python_install_all
47 }