dev-python/aioeventlet: Enable the test suites
[gentoo.git] / dev-python / aioeventlet / aioeventlet-0.5.1-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_4 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="asyncio event loop scheduling callbacks in eventlet"
11 HOMEPAGE="https://pypi.python.org/pypi/aioeventlet https://bitbucket.org/haypo/aioeventlet"
12 SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm64 ~x86"
17 IUSE="test"
18
19 RDEPEND="
20         dev-python/eventlet[${PYTHON_USEDEP}]
21         $(python_gen_cond_dep '>=dev-python/trollius-0.3[${PYTHON_USEDEP}]' 'python2_7')"
22 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 dev-python/aiotest[${PYTHON_USEDEP}]
25                 $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7') )"
26
27 python_test() {
28         # from tox.ini
29         "${PYTHON}" runtests.py -v || die "Tests fail with ${EPYTHON}"
30         "${PYTHON}" run_aiotest.py -v || die "Tests fail with ${EPYTHON}"
31 }