Replace pypi.python.org with pypi.org in HOMEPAGE
[gentoo.git] / dev-python / CacheControl / CacheControl-0.11.5.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
7
8 inherit distutils-r1 eutils
9
10 DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
11 HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.org/project/cachecontrol/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
17 IUSE="test"
18
19 RDEPEND="
20         dev-python/requests[${PYTHON_USEDEP}]
21         >=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
22 DEPENDS="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? ( dev-python/pytest[${PYTHON_USEDEP}]     )
25 "
26
27 # Not included
28 RESTRICT=test
29
30 python_test() {
31         py.test -v -v || die
32 }
33
34 pkg_postinst() {
35         optfeature "Redis based caches" dev-python/redis-py
36 }