dev-python/CacheControl: Restrict tests bacause they are not included
[gentoo.git] / dev-python / CacheControl / CacheControl-0.11.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
8
9 inherit distutils-r1 eutils
10
11 DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
12 HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
18 IUSE="test"
19
20 RDEPEND="
21         dev-python/requests[${PYTHON_USEDEP}]
22         >=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
23 DEPENDS="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? ( dev-python/pytest[${PYTHON_USEDEP}]     )
26 "
27
28 # Not included
29 RESTRICT=test
30
31 python_test() {
32         py.test -v -v || die
33 }
34
35 pkg_postinst() {
36         optfeature "Redis based caches" dev-python/redis-py
37 }