dev-python/BitVector: version bump.
[gentoo.git] / dev-python / BitVector / BitVector-3.4.8.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_5,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
11 HOMEPAGE="https://engineering.purdue.edu/kak/dist/ https://pypi.org/project/BitVector/"
12 SRC_URI="https://engineering.purdue.edu/kak/dist/${P}.tar.gz"
13 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
14 RDEPEND=""
15 LICENSE="PSF-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 python_test() {
22         "${PYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
23 }