dev-php/PEAR-Crypt_CHAP: keyworded 1.5.0-r3 for ia64, bug #703372
[gentoo.git] / dev-php / xdebug / xdebug-2.9.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5 PHP_EXT_NAME="xdebug"
6 PHP_EXT_INI="yes"
7 PHP_EXT_ZENDEXT="yes"
8 PHP_EXT_INIFILE="2.6.0-xdebug.ini"
9
10 USE_PHP="php7-2 php7-3 php7-4"
11
12 MY_PV="${PV/_/}"
13 MY_PV="${MY_PV/rc/RC}"
14
15 S="${WORKDIR}/${PN}-${MY_PV}"
16
17 inherit php-ext-source-r3
18
19 KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
20
21 DESCRIPTION="A PHP debugging and profiling extension"
22 HOMEPAGE="https://xdebug.org/"
23 # Using tarball from GitHub for tests
24 #SRC_URI="https://pecl.php.net/get/${PN}-${MY_PV}.tgz"
25 SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
26 LICENSE="Xdebug"
27 SLOT="0"
28 IUSE=""
29
30 DEPEND=""
31 RDEPEND="${DEPEND}
32                 ~dev-php/xdebug-client-${PV}"
33 DOCS=( README.rst CREDITS )
34 PHP_EXT_ECONF_ARGS=()
35
36 pkg_postinst() {
37         ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
38         ewarn "installed as a dependency, and not all users will want xdebug to be"
39         ewarn "enabled by default. If you want to enable it, you should edit the"
40         ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
41         ewarn "call xdebug_enable() in your code."
42 }