dev-php/symfony-filesystem: bump to v3.4.36
[gentoo.git] / dev-php / webmozart-assert / webmozart-assert-1.2.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN/webmozart-//}"
7
8 DESCRIPTION="Assertions to validate method input/output with nice error messages"
9 HOMEPAGE="https://github.com/webmozart/assert"
10 SRC_URI="https://github.com/webmozart/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
15 IUSE=""
16
17 S="${WORKDIR}/${MY_PN}-${PV}"
18
19 RDEPEND="dev-php/fedora-autoloader
20         >=dev-lang/php-5.6:*"
21
22 src_install() {
23         insinto /usr/share/php/Webmozart/Assert
24         doins -r src/*
25         doins "${FILESDIR}/autoload.php"
26 }