dev-python/werkzeug: stable 0.16.1 for sparc, bug #719946
[gentoo.git] / dev-php / sebastian-type / sebastian-type-1.1.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_PN="type"
7
8 DESCRIPTION="Collection of value objects that represent the types of the PHP type system"
9 HOMEPAGE="http://phpunit.de"
10 SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
15 IUSE=""
16
17 S="${WORKDIR}/${MY_PN}-${PV}"
18
19 RDEPEND="dev-php/fedora-autoloader
20         >=dev-lang/php-7.2:*"
21
22 src_install() {
23         insinto /usr/share/php/SebastianBergmann/Type
24         doins -r src/*
25         doins "${FILESDIR}/autoload.php"
26 }