www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-php / sebastian-exporter / sebastian-exporter-3.1.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_PN="${PN/sebastian-//}"
7
8 DESCRIPTION="Export PHP variables for visualization"
9 HOMEPAGE="http://phpunit.de"
10 SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
15 IUSE=""
16
17 S="${WORKDIR}/${MY_PN}-${PV}"
18
19 RDEPEND="dev-php/fedora-autoloader
20         =dev-php/sebastian-recursion-context-3*
21         =dev-lang/php-7*:*"
22
23 src_install() {
24         insinto /usr/share/php/SebastianBergmann/Exporter
25         doins -r src/*
26         doins "${FILESDIR}/autoload.php"
27 }