dev-php/sebastian-environment: Keyword remaining arches for Bug 613766
[gentoo.git] / dev-php / sebastian-environment / sebastian-environment-2.0.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN/sebastian-//}"
7
8 DESCRIPTION="Helps writing PHP code that has runtime-specific execution paths"
9 HOMEPAGE="http://phpunit.de"
10 SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
15 IUSE=""
16
17 S="${WORKDIR}/${MY_PN}-${PV}"
18
19 RDEPEND="dev-php/fedora-autoloader
20         >=dev-lang/php-5.6:*"
21
22 src_install() {
23         insinto /usr/share/php/SebastianBergmann/Environment
24         doins -r src/*
25         doins "${FILESDIR}/autoload.php"
26 }