dev-php/phpdocumentor-reflection-docblock: amd64 stable wrt bug #635356
[gentoo.git] / dev-php / phpdocumentor-reflection-docblock / phpdocumentor-reflection-docblock-3.1.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="ReflectionDocBlock"
7 MY_VENDOR="phpDocumentor"
8
9 DESCRIPTION="Provide support for annotations via DocBlocks"
10 HOMEPAGE="https://www.phpdoc.org"
11 SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
16 IUSE=""
17
18 S="${WORKDIR}/${MY_PN}-${PV}"
19
20 RDEPEND="dev-php/fedora-autoloader
21         <dev-php/phpdocumentor-reflection-common-2
22         <dev-php/phpdocumentor-type-resolver-1
23         <dev-php/webmozart-assert-2
24         >=dev-lang/php-5.6:*"
25
26 src_install() {
27         insinto /usr/share/php/${MY_VENDOR}/${MY_PN}
28         doins -r src/*
29         doins "${FILESDIR}/autoload.php"
30 }