dev-php/phpdocumentor-reflection-common: add ~arm keyword (bug 613766)
[gentoo.git] / dev-php / phpdocumentor-reflection-common / phpdocumentor-reflection-common-1.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="ReflectionCommon"
7 MY_VENDOR="phpDocumentor"
8
9 DESCRIPTION="Common reflection classes used by phpdocumentor to reflect the code structure"
10 HOMEPAGE="https://www.phpdoc.org"
11 SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
16 IUSE=""
17
18 S="${WORKDIR}/${MY_PN}-${PV}"
19
20 RDEPEND="dev-php/fedora-autoloader
21         >=dev-lang/php-5.6:*"
22
23 src_install() {
24         insinto /usr/share/php/${MY_VENDOR}/${MY_PN}
25         doins -r src/*
26         doins "${FILESDIR}/autoload.php"
27 }