dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-php / pecl-xdiff / pecl-xdiff-2.0.1-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PHP_EXT_NAME="xdiff"
7 PHP_EXT_PECL_PKG="xdiff"
8 DOCS=( README.API )
9
10 USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
11
12 inherit php-ext-pecl-r3
13
14 USE_PHP="php7-0 php7-1 php7-2 php7-3 php7-4"
15
16 KEYWORDS="~amd64 ~x86"
17
18 DESCRIPTION="PHP extension for generating diff files"
19 LICENSE="PHP-3.01"
20 SLOT="7"
21
22 DEPEND="
23         php_targets_php7-0? ( dev-libs/libxdiff )
24         php_targets_php7-1? ( dev-libs/libxdiff )
25         php_targets_php7-2? ( dev-libs/libxdiff )
26         php_targets_php7-3? ( dev-libs/libxdiff )
27         php_targets_php7-4? ( dev-libs/libxdiff )
28 "
29 RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-xdiff:0[php_targets_php5-6] )"
30
31 src_prepare() {
32         if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
33                 php-ext-source-r3_src_prepare
34         else
35                 eapply_user
36         fi
37 }
38
39 src_configure() {
40         if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
41                 local PHP_EXT_ECONF_ARGS=()
42                 php-ext-source-r3_src_configure
43         fi
44 }
45
46 src_install() {
47         if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
48                 php-ext-pecl-r3_src_install
49         fi
50 }