www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-php / pecl-raphf / pecl-raphf-2.0.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 PHP_EXT_NAME="raphf"
7 PHP_EXT_INI="yes"
8 PHP_EXT_ZENDEXT="no"
9 PHP_EXT_ECONF_ARGS=""
10 PHP_INI_NAME="30-${PHP_EXT_NAME}"
11
12 USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
13
14 inherit php-ext-pecl-r3
15
16 # Only really build for 7.x
17 USE_PHP="php7-1 php7-2 php7-3 php7-4"
18
19 KEYWORDS="~amd64 ~x86"
20
21 DESCRIPTION="A reusable, persistent handle and resource factory API"
22 LICENSE="BSD-2"
23 SLOT="7"
24 IUSE=""
25
26 RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
27
28 src_prepare() {
29         if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
30                 php-ext-source-r3_src_prepare
31         else
32                 default_src_prepare
33         fi
34 }
35
36 src_install() {
37         if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
38                 php-ext-pecl-r3_src_install
39         fi
40 }