dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-php / pecl-eio / pecl-eio-2.0.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PHP_EXT_NAME="eio"
6 PHP_EXT_INI="yes"
7 PHP_EXT_ZENDEXT="no"
8 DOCS=( README.md )
9
10 USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
11 inherit php-ext-pecl-r3
12
13 KEYWORDS="~amd64 ~x86"
14 LICENSE="PHP-3.01"
15
16 DESCRIPTION="PHP wrapper for libeio library"
17 LICENSE="PHP-3"
18 SLOT="0"
19 IUSE="debug"
20
21 src_configure() {
22         local PHP_EXT_ECONF_ARGS="--with-eio $(use_enable debug eio-debug)"
23         php-ext-source-r3_src_configure
24 }