dev-python/pyfeyn: cleaning old
[gentoo.git] / dev-php / pecl-drizzle / pecl-drizzle-0.4.2-r3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 PHP_EXT_NAME="drizzle"
8 PHP_EXT_INI="yes"
9 PHP_EXT_ZENDEXT="no"
10
11 USE_PHP="php5-6 php5-5 php5-4"
12
13 inherit php-ext-pecl-r2 eutils
14
15 KEYWORDS="~amd64"
16
17 DESCRIPTION="PHP extension using libdrizzle library to provide communcation with Drizzle and MySQL databases"
18 LICENSE="PHP-3"
19 SLOT="0"
20 IUSE=""
21
22 DEPEND="dev-db/drizzle"
23 RDEPEND="${DEPEND}"
24
25 src_prepare() {
26         local slot orig_s="${PHP_EXT_S}"
27         for slot in $(php_get_slots); do
28                 php_init_slot_env ${slot}
29                 epatch "${FILESDIR}/${P}-php54.patch"
30                 #Fix tests
31                 mkdir ext || die
32                 mv drizzle_*.phpt ext || die
33         done
34         php-ext-source-r2_src_prepare
35 }