dev-perl/Test-MockRandom: Blind stable on arm, critical bug 667774
[gentoo.git] / dev-php / pecl-crack / pecl-crack-0.4-r6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PHP_EXT_NAME="crack"
7 PHP_EXT_INI="yes"
8 PHP_EXT_ZENDEXT="no"
9 PHP_EXT_EXTRA_ECONF=""
10 DOCS=( EXPERIMENTAL )
11
12 USE_PHP="php5-6 php7-0 php7-1"
13
14 inherit php-ext-pecl-r3
15
16 KEYWORDS="amd64 ppc ppc64 x86"
17
18 DESCRIPTION="PHP interface to the cracklib libraries"
19 LICENSE="PHP-3 CRACKLIB"
20 SLOT="0"
21 IUSE=""
22 # Patch for http://pecl.php.net/bugs/bug.php?id=5765
23 PATCHES=( "${FILESDIR}/fix-php-5-4-support.patch"
24 "${FILESDIR}/fix-pecl-bug-5765.patch"
25 "${FILESDIR}/${PV}-php7.patch"
26 )