dev-python/click-default-group: arm64 keyworded (bug #700918)
[gentoo.git] / dev-php / myclabs-deepcopy / myclabs-deepcopy-1.6.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="DeepCopy"
7
8 DESCRIPTION="Create deep copies (clones) of your objects"
9 HOMEPAGE="https://github.com/myclabs/DeepCopy"
10 SRC_URI="https://github.com/myclabs/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
15 IUSE=""
16
17 S="${WORKDIR}/${MY_PN}-${PV}"
18
19 RDEPEND="dev-php/fedora-autoloader
20         >=dev-lang/php-5.6:*"
21
22 src_install() {
23         insinto /usr/share/php/myclabs
24         doins -r src/*
25         insinto /usr/share/php/myclabs/DeepCopy
26         doins "${FILESDIR}/autoload.php"
27 }