dev-php/pecl-mongodb: bump to 1.5.3
[gentoo.git] / dev-php / libchart / libchart-1.3.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Easy-to-use chart creation library for PHP"
7 HOMEPAGE="http://naku.dohcrew.com/libchart https://github.com/naku/libchart"
8 SRC_URI="https://github.com/naku/${PN}/releases/download/release/${PV}/${P}.tar.gz"
9
10 LICENSE="GPL-3 BitstreamVera"
11 KEYWORDS="~amd64 ~x86"
12 SLOT=0
13 IUSE="examples"
14
15 DEPEND=""
16 RDEPEND="dev-lang/php:*[gd,truetype]"
17
18 S="${WORKDIR}/${PN}"
19
20 src_install() {
21         dodoc "${PN}"/{ChangeLog,README}
22
23         if use examples ; then
24                 # PHP won't run a compressed example...
25                 docompress -x "/usr/share/doc/${PF}/demo"
26                 dodoc -r demo/
27         fi
28
29         insinto "/usr/share/php/${PN}"
30         doins -r "${PN}"/{classes,fonts,images}
31 }