dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-php / fedora-autoloader / fedora-autoloader-0.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Fedora's Static PSR-4, PSR-0, and classmap autoloader"
7 HOMEPAGE="https://github.com/php-fedora/autoloader"
8 SRC_URI="https://github.com/php-fedora/autoloader/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~s390 sparc x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="dev-lang/php:*"
17 DEPEND="
18         test? (
19                 ${RDEPEND}
20                 dev-php/phpunit )"
21
22 S="${WORKDIR}/autoloader-${PV}"
23
24 src_install() {
25         insinto "/usr/share/php/Fedora/Autoloader"
26         doins -r src/.
27         dodoc CHANGELOG.md README.md
28 }
29
30 src_test() {
31         phpunit || die "test suite failed"
32 }