dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-php / doctrine-instantiator / doctrine-instantiator-1.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN/doctrine-//}"
7
8 DESCRIPTION="Utility to instantiate objects in PHP without invoking their constructors"
9 HOMEPAGE="https://github.com/doctrine/instantiator"
10 SRC_URI="https://github.com/doctrine/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
15 IUSE=""
16
17 S="${WORKDIR}/${MY_PN}-${PV}"
18
19 RDEPEND="dev-php/fedora-autoloader
20         >=dev-lang/php-7.1:*"
21
22 src_install() {
23         insinto /usr/share/php/
24         doins -r src/*
25         insinto /usr/share/php/Doctrine/Instantiator
26         doins "${FILESDIR}/autoload.php"
27 }