dev-php/composer: bump to 1.7.3
[gentoo.git] / dev-php / composer / composer-1.7.3.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Dependency Manager for PHP"
7 HOMEPAGE="https://github.com/composer/composer"
8 SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13
14 RDEPEND="
15         dev-lang/php:*[curl]
16         >=dev-php/ca-bundle-1.1.2
17         >=dev-php/psr-log-1.0.2
18         dev-php/fedora-autoloader
19         >=dev-php/json-schema-5.2.7
20         >=dev-php/jsonlint-1.7.1
21         >=dev-php/phar-utils-1.0.1
22         >=dev-php/semver-1.4.2
23         >=dev-php/spdx-licenses-1.4.0
24         >=dev-php/symfony-console-2.8.43
25         >=dev-php/symfony-filesystem-2.8.43
26         >=dev-php/symfony-finder-2.7.20
27         >=dev-php/symfony-process-2.8.43
28         >=dev-php/xdebug-handler-1.2.0"
29
30 src_install() {
31         insinto "/usr/share/${PN}"
32
33         # Composer expects the LICENSE file to be there, and the
34         # easiest thing to do is to give it what it wants.
35         doins -r src res LICENSE
36
37         insinto "/usr/share/${PN}/vendor"
38         newins "${FILESDIR}"/autoload-r1.php autoload.php
39
40         exeinto "/usr/share/${PN}/bin"
41         doexe "bin/${PN}"
42         dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
43
44         dodoc CHANGELOG.md README.md doc/*.md
45         dodoc -r doc/articles doc/faqs
46 }