dev-php/composer: Add version bump 1.5.5
[gentoo.git] / dev-php / composer / composer-1.5.2-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Dependency Manager for PHP"
7 HOMEPAGE="https://github.com/composer/composer"
8 SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13
14 RDEPEND="
15         dev-lang/php:*[curl]
16         >=dev-php/ca-bundle-1.0.0
17         >=dev-php/cli-prompt-1.0.0
18         >=dev-php/psr-log-1.0.2
19         dev-php/fedora-autoloader
20         >=dev-php/json-schema-3.0.0
21         >=dev-php/jsonlint-1.4.0
22         >=dev-php/phar-utils-1.0.0
23         >=dev-php/semver-1.0.0
24         >=dev-php/spdx-licenses-1.0.0
25         >=dev-php/symfony-console-2.7.9
26         >=dev-php/symfony-filesystem-2.7.20
27         >=dev-php/symfony-finder-2.7.20
28         >=dev-php/symfony-process-2.8.12"
29
30 src_install() {
31         insinto "/usr/share/${PN}"
32
33         # Composer expects the LICENSE file to be there, and the
34         # easiest thing to do is to give it what it wants.
35         doins -r src res LICENSE
36
37         insinto "/usr/share/${PN}/vendor"
38         doins "${FILESDIR}"/autoload.php
39
40         exeinto "/usr/share/${PN}/bin"
41         doexe "bin/${PN}"
42         dosym "/usr/share/${PN}/bin/${PN}" "/usr/bin/${PN}"
43
44         dodoc CHANGELOG.md README.md doc/*.md
45         dodoc -r doc/articles doc/faqs
46 }