dev-python/click-default-group: arm64 keyworded (bug #700918)
[gentoo.git] / dev-php / composer / composer-1.10.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Dependency Manager for PHP"
7 HOMEPAGE="https://github.com/composer/composer"
8 SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         dev-lang/php:*[curl]
18         >=dev-php/ca-bundle-1.1.3
19         >=dev-php/psr-log-1.1.0
20         dev-php/fedora-autoloader
21         >=dev-php/json-schema-5.2.7
22         >=dev-php/jsonlint-1.7.1
23         >=dev-php/phar-utils-1.0.1
24         >=dev-php/semver-1.4.2
25         >=dev-php/spdx-licenses-1.5.0
26         >=dev-php/symfony-console-2.8.48
27         >=dev-php/symfony-filesystem-2.8.48
28         >=dev-php/symfony-finder-2.8.49
29         >=dev-php/symfony-process-2.8.48
30         >=dev-php/xdebug-handler-1.3.1"
31
32 src_install() {
33         insinto "/usr/share/${PN}"
34
35         # Composer expects the LICENSE file to be there, and the
36         # easiest thing to do is to give it what it wants.
37         doins -r src res LICENSE
38
39         insinto "/usr/share/${PN}/vendor"
40         newins "${FILESDIR}"/autoload-r1.php autoload.php
41
42         exeinto "/usr/share/${PN}/bin"
43         doexe "bin/${PN}"
44         dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
45
46         dodoc CHANGELOG.md README.md doc/*.md
47         dodoc -r doc/articles doc/faqs
48 }