dev-php/PEAR-Crypt_CHAP: keyworded 1.5.0-r3 for ppc64
[gentoo.git] / dev-php / awl / awl-0.61.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Andrew McMillan's Web Libraries"
7 HOMEPAGE="https://gitlab.com/davical-project/awl"
8 SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
9
10 LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2+ LGPL-3+"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 BDEPEND="test? ( dev-php/phpunit )"
17 RDEPEND="dev-lang/php:*[pdo,postgres,xml]"
18
19 S="${WORKDIR}"
20
21 src_compile() {
22         :
23 }
24
25 src_test() {
26         phpunit tests/ || die "test suite failed"
27 }
28
29 src_install() {
30         einstalldocs
31         insinto /usr/share/php/${PN}
32         doins -r dba inc
33 }