Stable on hppa.
[gentoo.git] / dev-php / adodb / adodb-4.90.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-php/adodb/adodb-4.90.ebuild,v 1.2 2007/02/27 13:20:43 gmsoft Exp $
4
5 inherit php-lib-r1
6
7 KEYWORDS="~alpha ~amd64 hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
8 DESCRIPTION="Active Data Objects Data Base library for PHP."
9 HOMEPAGE="http://adodb.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/adodb/${PN}${PV//./}.tgz"
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 IUSE=""
14
15 S="${WORKDIR}/${PN}"
16
17 need_php_by_category
18
19 pkg_setup() {
20         ewarn "ADODB requires some form of SQL or ODBC support in your PHP."
21 }
22
23 src_install() {
24         # install php files
25         php-lib-r1_src_install . `find . -name '*.php' -print`
26
27         # install xsl files
28         php-lib-r1_src_install . xsl/*.xsl
29
30         # install documentation
31         dohtml docs/*.htm
32         dodoc *.txt xmlschema.dtd session/adodb-sess.txt pear/readme.Auth.txt
33 }