*/*: [QA] Use consistent function definition formatting
[gentoo.git] / dev-php / PEAR-VersionControl_SVN / PEAR-VersionControl_SVN-0.5.2-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit php-pear-r2
7
8 DESCRIPTION="Simple OO wrapper interface for the Subversion command-line client"
9 LICENSE="BSD"
10 SLOT="0"
11 KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
12 IUSE=""
13 RDEPEND=""
14
15 src_prepare() {
16         einfo "Patching SVN.php and SVN/Command.php to use proper paths by default"
17         sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN.php || die "sed failed"
18         sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN/Command.php || die "sed failed"
19         default
20 }