media-plugins/gst-plugins-srtp: bump to 1.12.2
[gentoo.git] / dev-php / PEAR-Text_Highlighter / PEAR-Text_Highlighter-0.7.3-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN/PEAR-/}"
7 MY_P="${MY_PN}-${PV}"
8
9 DESCRIPTION="A package for syntax highlighting"
10 HOMEPAGE="http://pear.php.net/package/${MY_PN}"
11 SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
12 LICENSE="PHP-3.01"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 # There is a documented dependency on XML_Parser, but that's only needed
18 # for development -- if you want to *generate* the PHP class files. The
19 # ones in the release are already pre-generated. The dependency on the
20 # XML_Serializer, on the other hand, is not documented but is requird
21 # by the XML output renderer.
22 RDEPEND="dev-lang/php
23         dev-php/PEAR-PEAR
24         dev-php/PEAR-XML_Serializer"
25
26 S="${WORKDIR}/${MY_P}"
27
28 src_install() {
29         dodoc README TODO
30
31         insinto /usr/share/php
32         doins -r Text
33 }