media-libs/portaudio: Version bump
[gentoo.git] / dev-php / PEAR-Net_Sieve / PEAR-Net_Sieve-1.5.2-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 MY_PN="${PN/PEAR-/}"
8
9 DESCRIPTION="An API for talking to sieve (RFC 3028) servers"
10 HOMEPAGE="https://github.com/roundcube/${MY_PN}"
11 SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
15 IUSE="sasl"
16
17 RDEPEND="dev-lang/php:*
18         dev-php/PEAR-PEAR
19         dev-php/PEAR-Net_Socket
20         sasl? ( dev-php/PEAR-Auth_SASL )"
21
22 S="${WORKDIR}/${MY_PN}-${PV}"
23
24 src_install() {
25         # Install into "Net" for backwards compatibility (that's where PEAR
26         # used to put things).
27         insinto /usr/share/php/Net
28         doins Sieve.php
29 }