dev-php/PEAR-Net_Sieve: Remove HOMEPAGE from SRC_URI
[gentoo.git] / dev-php / PEAR-Net_Sieve / PEAR-Net_Sieve-1.5.2-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN/PEAR-/}"
7
8 DESCRIPTION="An API for talking to sieve (RFC 3028) servers"
9 HOMEPAGE="https://github.com/roundcube/${MY_PN}"
10 SRC_URI="https://github.com/roundcube/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
14 IUSE="sasl"
15
16 RDEPEND="dev-lang/php:*
17         dev-php/PEAR-PEAR
18         dev-php/PEAR-Net_Socket
19         sasl? ( dev-php/PEAR-Auth_SASL )"
20
21 S="${WORKDIR}/${MY_PN}-${PV}"
22
23 src_install() {
24         # Install into "Net" for backwards compatibility (that's where PEAR
25         # used to put things).
26         insinto /usr/share/php/Net
27         doins Sieve.php
28 }