9ed68220b5b2e7d3fca77e41b86b4ec2f0fb1195
[gentoo.git] / dev-php / PEAR-Net_DNSBL / PEAR-Net_DNSBL-1.3.7-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN/PEAR-/}"
7 MY_P="${MY_PN}-${PV}"
8
9 DESCRIPTION="PHP library to query DNS blacklists"
10 HOMEPAGE="https://pear.php.net/package/Net_DNSBL"
11 SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
12 LICENSE="PHP-3.01"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 hppa ia64 sparc x86"
15 IUSE="examples"
16 RDEPEND="dev-lang/php:*
17         dev-php/PEAR-Cache_Lite
18         dev-php/PEAR-HTTP_Request2
19         dev-php/PEAR-Net_DNS
20         dev-php/PEAR-PEAR
21         examples? ( dev-lang/php:*[cli] dev-php/PEAR-Console_Getopt )"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_install() {
26         use examples && dodoc -r examples
27
28         insinto /usr/share/php
29         doins -r Net
30 }