app-emulation/vagrant: drop ruby23 comepletely
[gentoo.git] / dev-php / PEAR-Mail_Mime / PEAR-Mail_Mime-1.10.2-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit php-pear-r2
7
8 DESCRIPTION="Create and manipulate mime messages with PHP"
9
10 LICENSE="BSD"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
13 IUSE="test"
14 DEPEND="test? ( dev-php/PEAR-PEAR )"
15
16 src_test() {
17         # Requires the "pear" executable from dev-php/PEAR-PEAR.
18         pear run-tests tests || die
19
20         # The command succeeds regardless of whether or not the test suite
21         # passed, but this file is only written when there was a failure.
22         [[ -f run-tests.log ]] && die "test suite failed"
23 }