app-antivirus/clamav-0.99.2-r1: alpha stable
[gentoo.git] / dev-php / PEAR-Mail_Mime / PEAR-Mail_Mime-1.10.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit php-pear-r2
7
8 DESCRIPTION="Create and manipulate mime messages with PHP"
9
10 LICENSE="BSD"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
13 IUSE="test"
14
15 src_test() {
16         # Requires the "pear" executable from dev-php/PEAR-PEAR.
17         pear run-tests tests || die
18
19         # The command succeeds regardless of whether or not the test suite
20         # passed, but this file is only written when there was a failure.
21         [[ -f run-tests.log ]] && die "test suite failed"
22 }