dev-perl/Unicode-LineBreak: stable 2017.4.0-r1 for hppa, bug #723772
[gentoo.git] / dev-php / PEAR-MDB2 / PEAR-MDB2-2.5.0_beta5-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PEAR_PV=${PV/_beta/b}
7
8 inherit php-pear-r2
9
10 DESCRIPTION="Database Abstraction Layer"
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~s390 sparc x86"
14 IUSE="mssql mysql mysqli oci8 oci8-instant-client postgres sqlite"
15
16 RDEPEND=">=dev-php/PEAR-PEAR-1.9.1"
17
18 PDEPEND="mssql? ( >=dev-php/PEAR-MDB2_Driver_mssql-1.3.0_beta4 )
19         mysql? ( >=dev-php/PEAR-MDB2_Driver_mysqli-1.5.0_beta4 )
20         mysqli? ( >=dev-php/PEAR-MDB2_Driver_mysqli-1.5.0_beta4 )
21         oci8? ( >=dev-php/PEAR-MDB2_Driver_oci8-1.5.0_beta4 )
22         oci8-instant-client? ( >=dev-php/PEAR-MDB2_Driver_oci8-1.5.0_beta4 )
23         postgres? ( >=dev-php/PEAR-MDB2_Driver_pgsql-1.5.0_beta4 )"
24
25 DOCS=( docs/CONTRIBUTORS docs/MAINTAINERS docs/README docs/STATUS docs/TODO )
26 HTML_DOCS=( docs/datatypes.html)