dev-php/PEAR-Image_GraphViz: Version bump direct to stable
[gentoo.git] / dev-php / PEAR-Image_GraphViz / PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit php-pear-r2 vcs-snapshot
7
8 DESCRIPTION="PHP interface to AT&T's GraphViz tools"
9 SRC_URI="https://github.com/pear/Image_GraphViz/archive/3f8a01ae0597ca9d1d08a6e442cb0b153358fc0d.tar.gz -> ${PEAR_P}.tar.gz"
10 LICENSE="PHP-3"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 hppa ~ia64 ~sparc x86"
13 IUSE="test"
14 RDEPEND="media-gfx/graphviz"
15 DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
16 PATCHES=( "${FILESDIR}/Image_GraphViz-1.3.0-constructor.patch" )
17 S="${WORKDIR}/${PEAR_P}"
18
19 src_prepare() {
20         mv "${S}/package.xml" "${WORKDIR}" || die
21         default
22 }
23
24 src_test() {
25         peardev run-tests tests || die
26 }