dev-python/click-default-group: arm64 keyworded (bug #700918)
[gentoo.git] / dev-php / PEAR-Image_Color2 / PEAR-Image_Color2-0.1.5-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit php-pear-r2
7
8 DESCRIPTION="Color conversion and mixing for PHP5"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15 DEPEND="test? ( >=dev-php/phpunit-5 )"
16
17 src_prepare() {
18         # Modernize tests
19         sed -i -e "/require_once 'PHPUnit\/Framework.php';/d" \
20                 -e "s/assertType('\(Image_[a-zA-Z2_]*\)',/assertInstanceOf(\1::class,/" \
21                 -e "s/assertType('array',/assertInternalType('array',/" \
22                 -e "s/assertType('string',/assertInternalType('string',/" \
23                 tests/*.php tests/Model/*.php || die
24         default
25 }
26
27 src_test() {
28         phpunit tests/AllTests.php || die
29 }