dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-php / PEAR-HTTP / PEAR-HTTP-1.4.1-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit php-pear-r2 eutils
7
8 DESCRIPTION="Miscellaneous HTTP utilities"
9 LICENSE="BSD"
10 SLOT="0"
11 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
12 IUSE="test"
13 RESTRICT="!test? ( test )"
14 DEPEND="test? ( dev-php/PEAR-PEAR )"
15
16 src_prepare() {
17         # fix nasty DOS linebreaks
18         edos2unix HTTP.php
19         default
20 }
21
22 src_test() {
23         pear run-tests tests || die "Tests failed"
24 }