media-plugins/gst-plugins-srtp: bump to 1.12.2
[gentoo.git] / dev-php / PEAR-DB / PEAR-DB-1.9.2-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit php-pear-r2
7
8 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
9
10 DESCRIPTION="Database abstraction layer for PHP"
11 LICENSE="PHP-3"
12 SLOT="0"
13 IUSE="test"
14 DEPEND="test? ( dev-php/PEAR-PEAR )"
15
16 DOCS=( doc/TESTERS doc/IDEAS doc/MAINTAINERS doc/STATUS )
17
18 src_test() {
19         # Requires the "pear" executable from dev-php/PEAR-PEAR, and also
20         # a working version of the cli SAPI eselected.
21         pear run-tests tests || die
22
23         # The command succeeds regardless of whether or not the test suite
24         # passed, but this file is only written when there was a failure.
25         [[ -f run-tests.log ]] && die "test suite failed"
26 }