dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-php / PEAR-Config / PEAR-Config-2.0.0_pre20140323-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit php-pear-r2 vcs-snapshot
7
8 DESCRIPTION="Provides multiple methods for configuration manipulation"
9 LICENSE="PHP-2.02"
10 SLOT="0"
11 KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
12 IUSE="test xml"
13 RESTRICT="!test? ( test )"
14 RDEPEND="xml? ( dev-php/PEAR-XML_Parser dev-php/PEAR-XML_Util )"
15 DEPEND="test? ( ${RDEPEND} )"
16 SRC_URI="https://github.com/pear/Config/archive/606a24034ad80f9d6ccb5a8b698b702b392e4674.tar.gz -> ${PEAR_P}.tar.gz"
17 DOCS=( docs/TODO )
18 HTML_DOCS=( docs/Apache.php docs/IniCommented.php docs/IniFromScratch.php )
19
20 src_prepare() {
21         # Move snapshot location to where the eclass expects
22         mv "${S}/package.xml" "${WORKDIR}/package.xml" || die
23         sed -i 's/&new/new/' test/phpt_test.php.inc || die
24         sed -i 's/& new/ new/' test/bug6441.phpt || die
25         eapply_user
26 }
27
28 src_test() {
29         pear run-tests test || die "Tests failed"
30 }