dev-libs/tomsfastmath: keyworded 0.13.1 for ppc64, bug #725414
[gentoo.git] / dev-perl / constant-defer / constant-defer-6.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR="KRYDE"
7 DIST_VERSION="6"
8 inherit perl-module
9
10 DESCRIPTION="constant subs with deferred value calculation"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 x86"
15 IUSE="test examples"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="virtual/perl-Carp"
19 DEPEND="virtual/perl-ExtUtils-MakeMaker
20         virtual/perl-Exporter
21         test? ( virtual/perl-Data-Dumper
22                 virtual/perl-Test
23                 virtual/perl-Test-Simple )"
24
25 src_install() {
26         perl-module_src_install
27         if use examples; then
28                 docompress -x /usr/share/doc/${PF}/examples
29                 dodoc -r examples
30         fi
31 }