profiles/arch/x86: Unmask py3.8+
[gentoo.git] / dev-perl / XML-Twig / XML-Twig-3.520.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MIROD
7 DIST_VERSION=3.52
8 inherit perl-module
9
10 DESCRIPTION="Process huge XML documents in tree mode"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
14 IUSE="nls test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=dev-perl/XML-Parser-2.31
19         >=virtual/perl-Scalar-List-Utils-1.230.0
20         >=virtual/perl-Encode-2.240.100_rc
21         >=dev-libs/expat-1.95.5
22         dev-perl/Tie-IxHash
23         dev-perl/XML-XPath
24         >=dev-perl/libwww-perl-6.40.0
25         >=dev-perl/HTML-Parser-3.690.0
26         nls? (
27                 >=dev-perl/Text-Iconv-1.2-r1
28         )
29 "
30 DEPEND="${RDEPEND}
31         virtual/perl-ExtUtils-MakeMaker
32         test? (
33                 >=dev-perl/XML-Handler-YAWriter-0.230.0
34                 >=dev-perl/XML-SAX-Writer-0.530.0
35         )
36 "
37
38 src_test() {
39         perl_rm_files "t/pod.t" "t/pod_coverage.t" "t/test_changes.t" \
40                 "t/test_kwalitee.t" "t/test_meta_json.t"
41         perl-module_src_test
42 }