dev-perl: Remove *-fbsd KEYWORDS
[gentoo.git] / dev-perl / XML-Twig / XML-Twig-3.520.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MIROD
7 DIST_VERSION=3.52
8 inherit perl-module
9
10 DESCRIPTION="Process huge XML documents in tree mode"
11
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
14 IUSE="nls test"
15
16 RDEPEND="
17         >=dev-perl/XML-Parser-2.31
18         >=virtual/perl-Scalar-List-Utils-1.230.0
19         >=virtual/perl-Encode-2.240.100_rc
20         >=dev-libs/expat-1.95.5
21         dev-perl/Tie-IxHash
22         dev-perl/XML-XPath
23         >=dev-perl/libwww-perl-6.40.0
24         >=dev-perl/HTML-Parser-3.690.0
25         nls? (
26                 >=dev-perl/Text-Iconv-1.2-r1
27         )
28 "
29 DEPEND="${RDEPEND}
30         virtual/perl-ExtUtils-MakeMaker
31         test? (
32                 >=dev-perl/XML-Handler-YAWriter-0.230.0
33                 >=dev-perl/XML-SAX-Writer-0.530.0
34         )
35 "
36
37 src_test() {
38         perl_rm_files "t/pod.t" "t/pod_coverage.t" "t/test_changes.t" \
39                 "t/test_kwalitee.t" "t/test_meta_json.t"
40         perl-module_src_test
41 }