profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / dev-perl / Video-ivtv / Video-ivtv-0.13-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit perl-module
7
8 DESCRIPTION="Video::ivtv perl module, for use with ivtv-ptune"
9 HOMEPAGE="http://ivtv.sourceforge.net"
10 SRC_URI="mirror://sourceforge/ivtv/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ia64 ppc x86"
15 IUSE=""
16
17 RDEPEND=""
18 DEPEND="${RDEPEND}"
19
20 src_configure() {
21         export OPTIMIZE="$CFLAGS"
22         perl-module_src_configure
23 }
24
25 # Requires /dev/video0 access, set DIST_TEST_OVERRIDE
26 # to circumvent
27 DIST_TEST="skip"
28
29 src_test() {
30         ebegin "Compile testing Video::ivtv ${PV}"
31                 perl -Mblib="${S}" -M"Video::ivtv ${PV} ()" -e1
32         if ! eend $?; then
33                 echo
34                 eerror "One or more modules failed compile:";
35                 eerror "  Video::ivtv ${PV}"
36                 die "Failing due to module compilation errors";
37         fi
38         perl-module_src_test
39 }