dev-perl/URI: Add ~m68k keyword wrt bug #665088
[gentoo.git] / dev-perl / URI / URI-1.730.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=ETHER
7 DIST_VERSION=1.73
8 inherit perl-module
9
10 DESCRIPTION="Uniform Resource Identifiers (absolute and relative)"
11
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15
16 RDEPEND="
17         virtual/perl-Carp
18         virtual/perl-Data-Dumper
19         virtual/perl-Encode
20         >=virtual/perl-Exporter-5.570.0
21         virtual/perl-File-Spec
22         >=virtual/perl-MIME-Base64-2
23         virtual/perl-Scalar-List-Utils
24         virtual/perl-libnet
25         virtual/perl-parent
26 "
27 DEPEND="${RDEPEND}
28         virtual/perl-ExtUtils-MakeMaker
29         test? (
30                 virtual/perl-File-Temp
31                 virtual/perl-Test
32                 dev-perl/Test-Needs
33                 >=virtual/perl-Test-Simple-0.960.0
34         )
35 "