dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / Tk-TableMatrix / Tk-TableMatrix-1.230.0-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=CERNEY
7 DIST_VERSION=1.23
8 inherit perl-module virtualx
9
10 DESCRIPTION="Create and manipulate tables in Perl + Tk"
11
12 LICENSE="Artistic"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
15 IUSE=""
16
17 DEPEND="dev-perl/Tk"
18 RDEPEND="${DEPEND}"
19
20 PATCHES=( "${FILESDIR}/${PN}-1.23-makemaker.patch" )
21
22 src_install() {
23         perl-module_src_install
24
25         # Clean out stray conflicting file - its generated by perl-tk already.
26         # Bug 169294
27         rm      "${D}"/${VENDOR_ARCH}/auto/Tk/pTk/extralibs.ld || die
28 }
29
30 src_test() {
31         virtx perl-module_src_test
32 }