dev-perl/Term-ReadLine-Gnu: add ~ppc64 keyword
[gentoo.git] / dev-perl / Text-CSV / Text-CSV-1.950.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=ISHIGAKI
7 DIST_VERSION=1.95
8 inherit perl-module
9
10 DESCRIPTION="Manipulate comma-separated value strings"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ppc ppc64 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test +xs"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         xs? ( >=dev-perl/Text-CSV_XS-1.20.0 )
19         virtual/perl-IO
20 "
21 DEPEND="
22         virtual/perl-ExtUtils-MakeMaker
23         test? (
24                 virtual/perl-Test-Simple
25         )
26 "
27
28 src_test() {
29         perl_rm_files t/00_pod.t
30         perl-module_src_test
31 }