sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-perl / Text-BibTeX / Text-BibTeX-0.850.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=AMBS
7 DIST_VERSION=0.85
8 DIST_EXAMPLES=( "examples/*" "scripts/*" )
9
10 inherit perl-module
11
12 DESCRIPTION="A Perl library for reading, parsing, and processing BibTeX files"
13
14 SLOT="0"
15 KEYWORDS="amd64 ~arm ~arm64 x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="
20         !dev-libs/btparse
21         virtual/perl-Encode
22         virtual/perl-Scalar-List-Utils
23         virtual/perl-Unicode-Normalize
24 "
25 DEPEND="${RDEPEND}
26         >=dev-perl/Config-AutoConf-0.160.0
27         >=dev-perl/ExtUtils-LibBuilder-0.20.0
28         >=virtual/perl-ExtUtils-CBuilder-0.270.0
29         >=dev-perl/Module-Build-0.360.300
30         test? (
31                 >=dev-perl/Capture-Tiny-0.60.0
32         )
33 "
34 src_prepare() {
35         sed -i -e "/#include <stdio.h>/a #include <string.h>"\
36                 btparse/tests/{tex,purify,postprocess,name,macro}_test.c || die
37         perl-module_src_prepare
38 }
39
40 src_install() {
41         perl-module_src_install
42         doheader btparse/src/btparse.h
43         doheader btparse/src/bt_config.h
44 }